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System Architecture – VIC7100

Program interface

(HTML5)

Existing Equipment
Vision Signal Converter

Optical Character Recognition Analysis

iSCADA

(Modbus)
PLC/SoftPLC

(Modbus)

REST API

(Json)

IoT Studio

(Modbus)



System Architecture – VIC7300

Existing Equipment
Vision Capture 

Card

Program interface
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MES

(SQL)

REST API

(Json)

IoT Studio

(Modbus)

VIC7300



Public

• VIC-7100

• VIC-7300

System Architecture

• VMWare

• VIC7000

Software Installation

• Get IP

• Login

• New Project

• Get Data

• Font Learning

• Target

• Page & Recognition

• Play Project

• Database

• Protocols

• Control

• Script

Build Project

Outline



Software Installation – VMware

• Install VMware Workstation Player

1. Execute VMware-player-15.0.2-

10952284 (Run as administrator)

2. Click Next until installation finished

change the installation path (*) if needed

Enhanced Keyboard Driver (*) is not 

required

1

2

*

*
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Software Installation – VMware

• Execute VMware Workstation Player



1

2

Software Installation – VMware

• Play Virtual Machine

1. Play VM : Click on Open a New Virtual Machine → Choose Windows 10 x64 – VIC7000

Training.vmx in the folder named Windows 10 x64 – VIC7000 Training



Software Installation – VMware

• Play Virtual Machine

2. Play VM : Select the new VM → Click Play virtual machine → Click I Moved It



Software Installation – VIC7000

• Execute VIC7000

1. Plug in Training Dongle : Choose Connect to a virtual machine



Software Installation – VIC7000

• Execute VIC7000

2. Execute VIC7000 : Click the shortcut of VIC7000 on your desktop

If an error window shows up, you need to check whether the USB 

dongle is actually plugged in, lit, linked to the VM or not.



Software Installation – VIC7000

• Language

Click Settings, and choose a suitable software language



Software Installation – VIC7000

• Port

Click Settings → Web Server Port. Default port is 80.

To set a new port, please make sure that it is available. Click on Test to check, hit OK to 

continue.
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Build Project – Get IP

• Get IP – Virtual Machine

• Get Remote IP: Go to the network status page then select used connection in Ethernet 

1

2

3



• Get IP – Virtual Machine

• Get Remote IP : IPv4 address is the IP address of VIC7000 server as shown below

Build Project – Get IP

4



• Get IP – Real Machine

• Set Static IP : Click on Network & Internet settings, the Setting window will appear, then 

choose Change adapter options

Build Project – Get IP

1

2

3



• Get IP – Real Machine

• Set Static IP : Double-click on desired adapter, the Status of the adapter window will 

appear, then click on Properties

Build Project – Get IP

4

5



• Get IP – Real Machine

• Set Static IP : Double-click on Internet Protocol Version 4 (TCP/IPv4), set IP address and 

Subnet mask

Finally, click on OK

Build Project – Get IP

6 7

89

The set IP address must be in the 

domain same with the IP address of the 

connecting computer

In other words, the first three fields must 

be the same 

For this example, the IP address of a 

connecting computer must be 

192.168.0.n, with n ranges from 1 to 

255 and must not be repeated



• Get IP – Real Machine

• Set Static IP : Click on Details… in Status window, then set IP address will appear 

Build Project – Get IP

10

11



Build Project – Login

• Entry to VIC7000

1. Open browser : Google Chrome or Microsoft Edge

2. Enter Server IP:port in URL field : By default, port is not required

View mode



Build Project – Login

• Login VIC7000

1. Click Login button in the top-right corner

2. Enter user or administrator name and password

User name is user, administrator name is admin, and 

their default password is 123456

If an admin logs in and stays idle for more than 30 mins, 

he will be forced to logout



Build Project – Login

user

General Mode (no administrative rights)



無管理權限的一般模式(user)

Build Project – Login

admin

General Mode (with administrative rights)



Build Project – Login

• Login Limits

• Allow up to 16 users to monitor the operation of VIC7000 in General Mode without 

administrative rights and View Mode at the same time

• While the administrator logging in VIC7000, other users cannot login, monitor, or operate 

VIC7000



Build Project – Login

• Replace Login

1. Click anywhere on the interface : A login window will show up

2. Enter administrator name and password

3. Click OK

When an administrator successfully logins, the current 

administrator will be forced to logout.



Build Project – Login

• Buttons

1. Database (only for 7300)

2. Load Project

3. Start/stop control

4. Start/stop project

5. Log

6. Administrator mode

7. Logout

8. System settings

9. About

1 2 3 84 5 6 7 9



Build Project – Login

• Log

• Record important software information

• Classified recording message

• Export as .txt

• Export path is the download path of the browser



Build Project – Login

• System Settings

• UI Language - English, Traditional 

Chinese, Simplified Chinese,

Japanese

• Change Password

• Auto Load Project

• Reset Project

• Left Mouse Button To Move Canvas

• Auto Load Page Image

• System Load

• System Save

• Enable Control Scheduler

• OCR Name Conversion Table

• Serial Port Control



Build Project – Login

• Database Settings

• Whether Save Image when recognition failed 

• Target Quantity

• Target_color Quantity

• Target_pattern Quantity

• OCR Quantity

• Color Quantity

• Pattern Quantity

• Calc Quantity

• Export Path & Select Export Path

• Backup Path & Select Backup Path

• Backup Time (hour)



Build Project – Login

• About

1. Version

2. Software license check

3. IP selection field of VIC7000

4. QR code of link VIC7000

5. Local user manual link

6. QR code of online user manual

7. VIC7000’s PC Free Disk Space

1

2

3

4 6

5

7



Build Project – Login

Administrator Mode



1 2 3 4 5 6 7 8 9 10

Build Project – Login

• Buttons

1. New project

2. Load project

3. Save project

4. Save as

5. Recognition config page

6. Script 

7. Monitor

8. Control

9. Link

10. Wizard



Build Project – New Project

• New project

1. Enter Project Name (Required and 

Unique)

2. Click OK

• Author

• Version

• Comment



Build Project – New Project

• Load Project

• Load project

• Delete project



管理模式

Build Project – New Project

• Recognition Config Page



Build Project – Get Data

• Image Source

• From File : Read images from a folder (.bmp or .tif)

• From Capture Card : Read images captured by capture card



Build Project – Get Data

• From File

1. Select the path of 

the folder where 

image is located

2. Read interval

The folder path is an 

address inside VIC7000 

computer hard drive

1

2



Remote
Local

Build Project – Get Data

• From File

• Get Image : Read images from a local folder or a remote folder



3

Build Project – Get Data

• From File

3. Start/Stop : Read and recognize images from a folder 

• Get Image : Read images from a local folder or a remote folder



Build Project – Get Data

• From Capture Card

1. Video Input : Generally, it is 

DVI_A (RGB/VGA)

2. Set Capture Frame Rate (fps)

• Video Quality

• Brightness

• Contrast

• Hue

• Saturation

• Sharpness

• Default : Restore quality 

parameters to default settings

2



Build Project – Get Data

• From Capture Card
2. Start/Stop : Continuously get images from capture card. It’s able to get and save 

images simultaneously

Get Image : Get an image from capture card

2
2



Build Project – Get Data

• From Capture Card

• Save Image : Right-click on the image, and follow instructions to save images to 

the local drive



Build Project – Font Learning

• Wizard : Learn OCR Font

1. Data Source

From File or From Capture Card



Build Project – Font Learning

• Wizard : Learn OCR Font

2. Source Settings 

From File : Image folder path, Read interval

From Capture Card : Video input signal type, Capture frame rate



Build Project – Font Learning

• Wizard : Learn OCR Font

3. Get Image

From File : Read images from a local folder or a remote folder

From Capture Card : Get an image from capture card



Build Project – Font Learning

• Wizard : Learn OCR Font

4. Segmentation Parameter : Adjust segmentation parameters to make characters recognizable



Build Project – Font Learning

• Segmentation Parameters

• Minimum Width/Height : The width/height of the smallest character. If the width/height of a 

character is smaller than this value, it will be discarded

• Maximum Width/Height : The width/height of the maximum character, if the width/height of a 

character is larger than this value, it will be discarded

• Character Spacing : The smallest space between adjacent characters. If the space between 

two characters is less than this value, they will be considers as two character separately

• Noise Area : Spotted area smaller than this value will be discarded. Adjusting this value will 

preserve the small character feature, like the dot above the letter i

• Chars Color : Black on White, White on Black, Dark on Light, Light on Dark

• Threshold : Adjust the image binarizing threshold



Build Project – Font Learning

• Segmentation Parameters

• Remove Narrow or Flat : If a character has its size value less than the minimum width/height 

or greater than the maximum width/height, this character will be discarded. It’s recommended 

to check this item again.

• Remove Border : Discard spots on edge of image/ROI 

• Cut Large Characters : If enabled, characters are split as much part as possible. This item is 

designed for characters that cannot be separated by adjusting threshold

• Relative Spacing(%) : When Cut Large Characters is checked, the empty vector is inserted 

between those split parts



Build Project – Font Learning

• Wizard : Learn OCR font

4. Segmentation parameter : Adjust segmentation parameters to make characters 

recognizable



Build Project – Font Learning

• Wizard : Learn OCR Font

5. Create New Font : Patterns height/width must be less than or equal to the current 

minimum height/width



Build Project – Font Learning

• Wizard : Learn OCR Font

6. Learn OCR Font

a. Learn Single Character : Click on the aimed character → Enter aimed Character into 

the field → Click OK

a



Build Project – Font Learning

• Wizard : Learn OCR Font

6. Learn OCR Font

b. Learn Multiple Character : Right-click on the image then select New ROI (or Click on 

New ROI button) → adjust location and size of ROI → Right-click on the image and 

click Set ROI  (or click Set ROI button)



Build Project – Font Learning

• Wizard : Learn OCR Font

6. Learn OCR Font

b. Learn Multiple Character : Click Learn Multiple Characters button → Enter Text → 

Click OK

b



Build Project – Font Learning

• Wizard : Learn OCR Font

6. Learn OCR Font

Simulation : Click Execute, and confirm the result in Recognition Result field



Build Project – Font Learning

• Wizard : Learn OCR Font

7. Save As Font File : Enter a Name for the font file



Build Project – Font Learning

• General : Learn OCR Font

1. Open OCR Font Learning Window

2. Get Image

a. Direct Load : Directly load 

images from Get Data

1

a



Build Project – Font Learning

• General : Learn OCR Font

2. Load Image

b. Open local image : Load images from a local folder

b



Build Project – Font Learning

• General : Learn OCR Font

2. Load Image

c. Open remote image : Load the image on a remote 

VIC7000 computer. Click on the preview block to enlarge 

selected image

c



Build Project – Font Learning

• General : Learn OCR Font

3. Segment Characters : Adjust segmentation parameters to make characters recognizable.



Build Project – Font Learning

• Segmentation Parameters

• Minimum Width/Height : The width/height of the smallest character. If the width/height of a 

character is smaller than this value, it will be discarded

• Maximum Width/Height : The width/height of the maximum character, if the width/height of a 

character is larger than this value, it will be discarded

• Character Spacing : The smallest space between adjacent characters. If the space between 

two characters is less than this value, they will be considers as two character separately

• Noise Area : Spotted area smaller than this value will be discarded. Adjusting this value will 

preserve the small character feature, like the dot above the letter i

• Chars Color : Black on White, White on Black, Dark on Light, Light on Dark

• Threshold : Adjust the image binarizing threshold



Build Project – Font Learning

• Segmentation Parameters

• Remove Narrow or Flat : If a character has its size value less than the minimum width/height 

or greater than the maximum width/height, this character will be discarded. It’s recommended 

to check this item again.

• Remove Border : Discard spots on edge of image/ROI 

• Cut Large Characters : If enabled, characters are split as much part as possible. This item is 

designed for characters that cannot be separated by adjusting threshold

• Relative Spacing(%) : When Cut Large Characters is checked, the empty vector is inserted 

between those split parts



Build Project – Font Learning

• General : Learn OCR Font

3. Segment Characters : Adjust segmentation parameters to make characters recognizable



Build Project – Font Learning

• General : Learn OCR Font

4. Create New Font : Patterns height/width must be less than or equal to characters minimum 

height/width

4



Build Project – Font Learning

• General : Learn OCR Font

5. Learn OCR Font

a. Learn Single Character : Click on the targeted character → Enter Character → Click OK

a



Build Project – Font Learning

• General : Learn OCR Font

5. Learn OCR Font

b. Learn Multiple Character : Right-click on the image and select New ROI → adjust the 

location and size of ROI → Right-click on the image and select Set ROI



Build Project – Font Learning

• General : Learn OCR Font

5. Learn OCR Font

b. Learn Multiple Character : Click Learn Multiple Characters → Enter Text → Click OK

b



Build Project – Font Learning

• General : Learn OCR Font

6. Simulation : Click Execute, and see the result in Recognition Result field

6



觀看模式無管理權限的一般模式(user)

Build Project – Font Learning

• General : Learn OCR Font

7. Save As Font File : Click Save As → Enter a Name for the font file → Click OK

7



Build Project – Font Learning

• General

• Segmentation Parameter : Each font file contains its own segmentation parameters. 

If those parameters are suffered any changes, recognition results will vary in consistent with them. 

Some characters require special segmentation parameter adjustment. Keep in mind that Create New 

Font File will clear previously learnt data. Therefore, users need to save the original font file, before 

create a new font file or adjust it.



Build Project – Font Learning

• General

• Keep training : Load font file and train more characters

1. Load : Load font file with Load button in OCR Font Learning window

1



Build Project – Font Learning

• General

• Keep training : Load font file and train more characters

2. Direct Load : Directly load font file used in recognition config page

2



Build Project – Font Learning

• General

• Keep Learning : Once segmentation parameters are re-adjusted, the recognition processes 

will apply new segmentation parameters. 

When learning process is finished → Click Save → Click OK to overwrite, repeating training 

process until all necessary characters are trained



Build Project – Font Learning

• General

• Edit Font File : Click Edit in OCR Font Learning window. Learnt samples and contents can 

be reviewed or deleted in Font window.



Build Project – Font Learning

• General

• Edit Font File : User can Edit learnt data in Font window. Enter changes in Result field, and 

click Apply. 



Build Project – Font Learning

• General : Learn OCR Font

8. Finish Learning : Click OK to close OCR Font Learning window



Build Project – Font Learning

• General : Learn OCR Font

8. Finish Learning : Back to OCR config page



Build Project – Target

• Wizard : Create a target

1. Data Source

From File or From Capture Card



Build Project – Target

• Wizard : Create a target

2. Source Settings 

From File : Image folder Path, Read interval

From Capture Card : Video input signal type, Capture frame rate



Build Project – Target

• Wizard : Create a target

3. Recognition

1. Matching target : Automatically select recognition page based on target matching result

2. Specify page : Directly specify the page to use

1

2



Build Project – Target

• Wizard : Create a target

4. Get Image

From File : Read images from local or remote folders

From Capture Card : Get an image from the capture card



Build Project – Target

• Wizard : Create a target

5. Simulate

Right-click on an image and click New ROI (or Click New ROI) → Resize location and size 

of ROI → Right-click on the image and click Set ROI (or Click Set ROI)



Build Project – Target

• Wizard : Create a target

5. Simulate

Click Load Font → Choose a font file used for recognition → Click Load

After selecting the font file, user can click preview to preview the learnt content of the font file



Build Project – Target

• Wizard : Create a target

5. Simulate

Click Simulate → Confirm the recognition result, which is used as TARGETs



Build Project – Target

• General : Create a Target

1. Recognition Method

1. Matching target : Automatically select recognition page based on target matching result

2. Specify page : Directly specify the page to use

1

1

2



Build Project – Target

• General : Create a Target

2. Get Image

a. From File : Read images from a local folder or a remote folder

2



Build Project – Target

• General : Create a Target

2. Get Image

b. From Capture Card : Get an image from capture card

2



Build Project – Target

• General : Create a Target

3. New ROI : Right-click on the image and select New ROI (or Click New ROI)

3

3



Build Project – Target

• General : Create a Target

4. Set ROI : Resize location and size of ROI → Right-click on image and click Set ROI (or 

Click Set ROI )

4

4



Build Project – Target

• General : Create a Target

5. Load Font : Click Load Font → Choose a font file used for recognition → Click Load

5



Build Project – Target

• General : Create a Target

6. Simulate : Click Simulate → Confirm the recognition result, which is used as TARGET

6



Build Project – Target

• General : Create a Target

• Multiple Target : Click Add icon → Repeat the aforementioned steps to create Targets

3

4

5

6

1



Build Project – Target

• General : Create a Target_Color

3. Create a TARGET_COLOR : Move cursor to Add icon → Select Color



Build Project – Target

• General : Create a Target_Color

4. New ROI : Right-click on image and click New ROI (or Click New ROI )

4

4



Build Project – Target

• General : Create a Target_Color

5. Set ROI : Resize and relocate the ROI → Right-click on the image and select Set ROI (or 

Click Set ROI ) The average RGB value of the ROI will be automatically obtained and 

be set as matching color

5

5



Build Project – Target

• General : Create a Target_Color

6. Set Matching Tolerance and Result Output : Set Matching Tolerance (RGB±) → Enter 

Matching Result Output

6



Build Project – Target

• General : Create a Target_Color

7. Simulate : Click Simulate → Confirm matching result, which is used as TARGET_COLOR

7



Build Project – Target

• General : Create a Target_Color

• Assign color matching : Click Color Picker → Enable eyedropper tool → Select the desired 

matching color in the image → The matching color will be set up automatically and confirm 

if it is correct. 



Build Project – Target

• General : Create a Target_Color

• Multiple Target_color : Click Add icon → repeat the aforementioned steps to create 

Target_colors

3

4

5

6
7



Build Project – Target

• General : Create a Target_Pattern

3. Create a TARGET_PATTERN : Move cursor to Add icon → select Pattern



Build Project – Target

• General : Create a Target_Pattern

4. New ROI : Right-click on the image and select New ROI (or Click New ROI)

4

4



Build Project – Target

• General : Create a Target_Pattern

5. Set ROI : adjust the location and size of the ROI → Right-click on image and select Set 

ROI (or Click Set ROI)

5

5



Build Project – Target

• General : Create a Target_Pattern

6. Load Matching Pattern : Click Pattern Load →  User can enter Pattern window, and the 

image will be loaded automatically

6



Build Project – Target

• General : Create a Target_Pattern

6. Load Matching Pattern : Right-click on the image → Select New Crop



Build Project – Target

• General : Create a Target_Pattern

6. Load Matching Pattern : Mark the matching pattern → Right-click on the image → Select 

Crop → OK



Build Project – Target

• General : Create a Target_Pattern

7. Set Matching Result Output : Enter Matching Result Output

7



Build Project – Target

• General : Create a Target_Pattern

8. Simulate : It’s recommended to use Gray Matching, it will speed up recognition speed.

Click Simulate → Confirm matching result, which is used as TARGET_PATTERN

8

8



Build Project – Target

• General

• Displacement Detection : Based on the position of TARGET_ 

PATTERN on the image where Target_Pattern is set

Detect Page Displacement : Make ROI of Targets and 

Target_Colors move in consistent with the position of TARGET_ 

PATTERN 

Detect Displacement : Make ROI of the page that match 

TARGET_PATTERN move with the position of 

TARGET_PATTERN



Build Project – Target

• General : Create a Target_Pattern

• Multiple Target_pattern : Click Add icon → repeat the aforementioned steps to create 

Target_patterns

3

4

5

6

7

8
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Build Project – Page & Recognition

• Wizard : Create a page

1. Data Source

From File or From Capture Card



• Wizard : Create a page

2. Source Settings 

From File : Image folder Path, Read interval

From Capture Card : Video input signal type, Capture frame rate

Build Project – Page & Recognition



• Wizard : Create a page

3. Targets : Set TARGET matching logical operators and conditions

Build Project – Page & Recognition

- : Skip matching

&& : AND

|| : OR



Build Project – Page & Recognition

• Wizard : Create a page

3. Targets : Set Target matching logical operators and conditions for the matching logical 

operators:

- : Skip matching this TARGET

|| : Execute || first. If one of the TARGETs set with || is satisfied, the page is 

considered as matched successfully.

&& : When || is not satisfied then the && will be considered, the page will only 

be considered as successfully if all of the TARGETs set with && are satisfied 

If more than one page matched successfully at the same time, the page with smaller index 

will be selected to be recognized. 



Build Project – Page & Recognition

• Wizard : Create a page

TARGET01 TARGET02 TARGET03 Used Page

Actual Result 125 125 155

PAGE01 || 120 && 130 && 155

PAGE02 || 125 && 125 && 150 Use this page

TARGET01 TARGET02 TARGET03 Used Page

Actual Result 125 125 155

PAGE01 && 120 && 125 && 155

PAGE02 || 110 && 125 && 155 Use this page



Build Project – Page & Recognition

TARGET01 TARGET02 TARGET03 Used Page

Actual Result 125 125 155

PAGE01 || 120 && 125 && 155 Use this page

PAGE02 || 125 && 125 && 150

TARGET01 TARGET02 TARGET03 Used Page

Actual Result 125 125 155

PAGE01 || 120 && 125 && 155 Use this page

PAGE02 || 110 && 125 && 155

• Wizard : Create a page



Build Project – Page & Recognition

• Wizard : Create a page

4. Get Image

From File : Read images from a local or remote folder

From Capture Card : Get an image from capture card



Build Project – Page & Recognition

• Wizard : Create a page

5. Simulate

Right-click on the image then select New ROI (or Click New ROI) → adjust the location and 

size of the ROI → Right-click on the image and select Set ROI (or Click Set ROI)



Build Project – Page & Recognition

• Wizard : Create a page

5. Simulate

Click Load Font → Choose a font file for recognition → Click Load → Click Simulate → 

Confirm the recognition results



Build Project – Page & Recognition

• General : Create a page

1. Create a Page : Click Add Page icon

2. Targets : Set TARGET matching logical operators and conditions

1

2 - : Skip matching

&& : AND

|| : OR



Build Project – Page & Recognition

• General : Create a page

2. Targets : Set TARGET matching logical operators and conditions for the matching logical 

operators:

- : Skip matching this TARGET

|| : Execute || first. If one of the TARGETs set with || is satisfied, the page is 

considered as matched successfully.

&& : When || is not satisfied then the && will be considered, the page will only 

be considered as successfully if all of the TARGETs set with && are satisfied 

If more than one page matched successfully at the same time, the page with smaller index  

will be selected to be recognized. 



Build Project – Page & Recognition

• General : Create a page

3. Create an OCR : Click Add icon → Get Image → Set ROI → Load a font file → Click 

Simulate to confirm the recognition result

1

2

3

4

5



Build Project – Page & Recognition

• Wizard : Create an OCR

1. Select a page : Choose the aimed page to 

create an OCR



Build Project – Page & Recognition

• Wizard : Create an OCR

2. Data Source

From File or From Capture Card



Build Project – Page & Recognition

• Wizard : Create an OCR

3. Source Settings 

From File : Image folder path, Read interval

From Capture Card : Video input signal type, Capture frame rate



Build Project – Page & Recognition

• Wizard : Create an OCR

4. Get Image

From File : Read images from a local or remote folder

From Capture Card : Get an image from capture card



Build Project – Page & Recognition

• Wizard : Create an OCR

5. Simulate

Right-click on the image then select New ROI (or Click New ROI) → Adjust the location 

and size of ROI → Right-click on an image then select Set ROI (or Click Set ROI)



Build Project – Page & Recognition

• Wizard : Create an OCR

5. Simulate

Click Load Font → Choose a font file used for recognition → Click Load → Click Simulate

→ Confirm the recognition result



Build Project – Page & Recognition

• General : Create an OCR
1. Select a page : Choose the aimed page to create an 

OCR

2. Create an OCR : Add icon

3. Get Image

a. From File : Read images from a local or remote 

folder

b. From Capture Card : Get an image from capture 

card

1

3

2



Build Project – Page & Recognition

• General : Create an OCR

4. New ROI : Right-click on an image then select New ROI (or Click New ROI)

4

4



Build Project – Page & Recognition

• General : Create an OCR

5. Set ROI : Adjust the location and size of ROI → Right-click on an image and select Set 

ROI (or Click Set ROI)

5

5



Build Project – Page & Recognition

• General : Create an OCR

6. Load Font : Click Load Font → Choose a font file used for recognition → Click Load

6



Build Project – Page & Recognition

• General : Create an OCR

7. Simulate : Click Simulate → Confirm the recognition result

7



Build Project – Page & Recognition

• OCR Config

• Input Parameters

- ROI X : Set X coordinates of ROI

- ROI Y : Set Y coordinates of ROI

- ROI Width : Set width coordinates of ROI

- ROI Height : Set Height coordinates of ROI

- Allow Empty Result : If it is checked, NG won’t show up when there is no character 

recognized in ROI

- Allow Recognition Rate : If recognition rate is lower than this value, NG will show up



Build Project – Page & Recognition

• General

• Symbol Recognition : Check on Allow Recognize Symbol → Click Load Symbol Font 

→ Choose a symbol font file used for recognition → Click Load

The Symbol font file that is used only for recognizing symbols.



Build Project – Page & Recognition

• General

• Symbol Recognition : Click View to confirm the content of OCR font and symbol font

In this sample, the OCR font is used to recognize numbers, and the symbol font is used to 

recognize minus sign and decimal point.
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• General

• Symbol Recognition : Click Simulate → Confirm the recognition result



Build Project – Page & Recognition

• General : Create an OCR

• Multiple OCR : Click Add icon → Repeat the aforementioned steps to create OCRs

2

4

5

6

7
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• General : Create a Color

4. Create a COLOR : Click on Add icon → Click Color

4
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• General : Create a Color

5. New ROI : Right-click on the image and select New ROI  (or Click New ROI button)

5

5
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• General : Create a Color

6. Set ROI : Adjust the location and size of ROI → Right-click on the image and select Set ROI 

(or Click Set ROI )  The average value of the RGB within the ROI is automatically obtained 

and be set as matching color

6

6
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• General : Create a Color

7. Set Matching Tolerance and Result Output : Set Matching Tolerance(RGB±) → Enter 

Matching Output Result

7
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• General : Create a Color

8. Simulate : Click Simulate → Confirm matching result

8
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• General : Create a Color

• Assign color matching : Click Color Picker → Enable eyedropper tool → Select the desired 

matching color in the image → The matching color will be set up automatically and confirm 

if it is correct.
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• General : Create a Color

• Multiple COLOR : Click Add icon → Repeat the aforementioned steps to create Colors

4

5

6

7

8
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• General : Create a Pattern

4. Create a PATTERN : Click Add icon on the page user wants to create a Pattern → Click 

Pattern

4
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• General : Create a Pattern

5. New ROI : Right-click on the image and select New ROI (or Click New ROI )

5

5
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• General : Create a Pattern

6. Set ROI : Adjust the location and size of ROI → Right-click on the image then select Set 

ROI (or Click Set ROI )

6

6
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• General : Create a Pattern

7. Load Matching Pattern : Click Pattern Load → Pattern window will appear, and an image 

will be loaded automatically

7
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• General : Create a Pattern

7. Load Matching Pattern : Right-click on the image → Select New Crop
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• General : Create a Pattern

7. Load Matching Pattern : Mark the matching pattern → Right-click on the image 

→ Select Crop → Click OK
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• General : Create a Pattern

8. Set Matching Result Output : Enter the Output of the Matching Result

8
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• General : Create a Pattern

9. Simulate : It’s recommended to check Gray Matching to speed up recognition processes. 

Click Simulate → Confirm matching result

9

8
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• General

• Displacement Detection : Based on the positions of 

PATTERNs on the image where Patterns are set

Detect Page Displacement : Making ROI of OCRs and 

Colors move with the positions of PATTERNs



Build Project – Page & Recognition

• General : Create a Pattern

• Multiple PATTERN : Click Add icon → Repeat the aforementioned steps to create Patterns

4

5

6

7

9

8

9



Build Project – Play Project

• Monitor

1. Start/Stop : Get images and push them into recognition continuously

2. Snap : Get an image and process recognition on it

3. Control Start/Stop : Play the control file

123

Recognition results will 

not be stored in Database 

and transported through 

Protocols.

While recognition process 

is running, Scripts will be 

executed.
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• Save Project

1. Save Project : Click Save 2.   Click OK

1

2
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• Play Project

1. Back to User Mode 1
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• Play Project

2. Click Start Project

2
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• Stop Warning

If user switch to administrator mode while the project is playing, the project will be interrupted.         

Click on Administrator Mode → the Warning window will appear→ Click OK

Then user can switch to administrator mode to go on
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• Use Database

1. Enter Database Page : Click DB in User Mode

1



Build Project – Database

• Use Database

2. Set Searching Parameters : Set the amount of Targets, 

Target_Colors, Target_Patterns, OCRs, Colors, Patterns, 

CALC. Date, Keyword of Page, Result 

3. Search : Click Search

3

2
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• Use Database

4. Searching Result : Seeking data following given parameters.  A small page contains 20 

records, and a large page contains 10 small pages
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• Login Limit

Only allow one person logs in and operates
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• Save Image

VIC7000 will save images into Database when recognition failed (NG or No Matching) (Enabled 

in System Setting window). Those saved images could be used for later training
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• Skip Repeated Data

VIC7000 can skip repeated data while storing data in database(Enabled in System Setting 

window). It is recommended when capture frame rate is high and repeated data occurs.
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• Export and Backup

VIC7000 allows users to export the searching results to .csv, .xls, .xlsb. Export Path is on 

VIC7000 PC and can be adjusted in System Settings window

Data within a period of 7-day will be continuously stored and extracted as .xlsb everyday (FIFO). 

Backup Path is set in VIC7000 PC and can be adjusted in System Setting window.
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• Remotely Download File

Click File icon to remotely download Export and Backup file in Download File window
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• Remotely Download File

Choose the file which user wants to download → Click Download

Download path is same as browser default
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• Database Notes

1. VIC7000 has a hardware remaining capacity detection mechanism. If the available capacity is 

less than 100G, the alert will show up and record in Log. Data will continue to be stored in 

Database at this state. If the available capacity is less than 50G, the alert will show up and record 

in Log. New data will replace the older data at this state.

2. VIC7000 has an automatic shutdown of saving image mechanism, which is checked every 

minute to let users know that whether it is enabled or not. If it is enabled, it will be recorded in Log. 

When the number of saved images exceed a threshold in a minute, this mechanism will be 

enabled. At this moment, Data will continue to be stored and image will not be saved when 

recognition failed. 

If the number of failure recognition occurring in a minute is less than the threshold, this 

mechanism will be turned off. Otherwise, this mechanism will still be enabled.

failure recognition means that recognition result is NG or No Matching.
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• Database Notes

3. The maximum number of data lines exported to a file is one million. If there more than one 

million lines of data exported at a moment, it will be divided to multiple files.

4. VIC7000 will backup data to a .xlsb file every day automatically. It takes more a half an hour, 

according the amount of data backed up. When backup process is running, it should avoid editing 

projects.
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Build Project – Protocols

TCP/IP is referred to Internet protocol suite. Different computers or operating environments can 

communicate with each other through this protocol. It includes two core protocols : TCP 

(Transmission Control Protocol) and IP (Internet Protocol) .

TCP/IP provides end-to-end data communication. There are two roles : Server or Client. It 

allows multiple Servers and Clients, which are connected through IP address and TCP port.

VIC7000 plays a role as Server.
Client 1

IP : xxx.xxx.xxx.xxx

Port : n

Client 2

IP : xxx.xxx.xxx.xxx

Port : n

Client k

IP : xxx.xxx.xxx.xxx

Port : n

…

Server 1

IP : xxx.xxx.xxx.xxx

Port : n

Server 2

IP : xxx.xxx.xxx.xxx

Port : n

Server k

IP : xxx.xxx.xxx.xxx

Port : n

…
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• Link Config

1. Enter Link page : In administrator page

2. Choose TCP/IP

3. Enter Port

4. Click Add

1

2

3
4

Remove Link
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• Link Testing : Use the client function of TCP Test Tools 

1. Enter IP and Port 2.    Click Connect

1 1
2
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• Link Testing

3. Check Data Log : Output data type is ASCII
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Modbus is a serial communications protocol originally published by Modicon in 1979 for use 

PLCs. 

Modbus has become a standard communication protocol and is now a commonly available 

means of connecting industrial electronic devices. Modbus is commonly used to connect with PLC 

and SCADA software. Versions of the Modbus protocol exist for serial port and for Ethernet and 

other protocol that the Internet protocol suite.
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• Modbus

• Use Modbus TCP, VIC7000 plays the role as Server

• Recognition data is stored in Input Status and Input Register

• Coil Status and Holding Register is for Script Editor output, external writing and controlling VIC

Client 1

IP : xxx.xxx.xxx.xxx

Port : n

Client 2

IP : xxx.xxx.xxx.xxx

Port : n

Client k

IP : xxx.xxx.xxx.xxx

Port : n

…

Server 1

IP : xxx.xxx.xxx.xxx

Port : n

Server 2

IP : xxx.xxx.xxx.xxx

Port : n

Server k

IP : xxx.xxx.xxx.xxx

Port : n

…

Address Name Data Type Type

0X0001 ~ 0X9999 Coil Status Bit R/W

1X0001 ~ 1X9999 Input Status Bit R

3X0001 ~ 3X9999 Input Register Word R

4X0001 ~ 4X9999 Holding Register Word R/W
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• Modbus

• Little – Endian

Fill in data from lower 

bits

A B C \0

42 41 0 43

3x12626 3x12627

OCR01 Result

Modbus Input Register
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Input Status (1X)

Address Content

10001
Project playing Status

1 = Playing      0 = Stop

10002
Whether there is a user logging in.

1 = Yes      0 = No

10003
Whether the free storage is lower than 100G

1 = Yes      0 = No

10004
Whether the free storage is lower than 50G

1 = Yes      0 = No

10005
Whether storing images is stopped.

1 = Yes      0 = No

10006 Recognition result

0 = Pass     1 = NG 2 = No Matching10007

Bit 7 Bit 6 Sum Result

0 0 0 Pass

0 1 1 NG

1 0 2 No Matching

• Address Mapping – Input Status : System Bit

Store system information. The Output data type is Boolean. Its length is 1 bit.

10008
Control playing status

1 = Playing      0 = Stop

10009
Whether serial port control is 

enabled.

1 = Yes      0 = No

10010
The status of serial port control

1 = Connecting      0 = Disconnecting
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Input Status (1X)

Address Content

10101 MODBUSBIT00

10102 MODBUSBIT01

10103 MODBUSBIT02

10104 MODBUSBIT03

10105 MODBUSBIT04

10106 MODBUSBIT05

• Address Mapping – Input Status : MODBUSBIT

Customizing Store Script output. The output data type is Boolean. Its length is 1 bit.

Input Status (1X)

Address Range Content

10101  ~ 10200 MODBUSBIT00 ~ MODBUSBIT99
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• Address Mapping – Input Register (Int) : PAGE_NO, TARGET_COUNT, OCR_COUNT,

TARGET_COLOR_COUNT, COLOR_COUNT, TARGET_PATTERN_COUNT, PATTERN_COUNT

Store the index of the current page and the number of target_color, target_pattern, OCR, color, pattern. The 

output data type is Int32. Its length is 2 words.

Input Register (3X)

Address Range Content

312501 ~ 312502 PAGE_NO

312503 ~ 312504 TARGET_COUNT

312505 ~ 312506 OCR_COUNT

312507 ~ 312508 TARGET_COLOR_COUNT

312509 ~ 312510 COLOR_COUNT

312511 ~ 312512 TARGET_PATTERN_COUNT

312513 ~ 312514 PATTERN_COUNT
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Input Register (3X)

Address Range Content

30126 ~ 30250 Target01 (String)

30251 ~ 30375 Target02 (String)

30376 ~ 30500 Target03 (String)

30501 ~ 30625 Target04 (String)

30626 ~ 30750 Target05 (String)

• Address Mapping – Input Register (String) : TARGET, OCR, CALC, MODBUSSTR

Store recognition results of targets & OCRs, script calculated results and Modbus custom string 

outputs. The output data type is ASCII. Its length is 125 words.

Input Register (3X)

Address Range Content

312626 ~ 325000 OCR01 ~ 99 (String)

325001 ~ 337500 CALC00 ~ 99 (String)

337501 ~ 350000 MODBUSSTR00 ~ 99
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• Address Mapping – Input Register (Int) : TARGET, OCR, MODBUSINT, MODBUSUINT

If recognition result contents of OCR and target is number, they will be converted to number. With 

the data type is Int32 and Its length is 2 words.

Input Register (3X)

Address Range Content

350003 ~ 350004 Target01 (Int)

350005 ~ 350006 Target02 (Int)

350007 ~ 350008 Target03 (Int)

350009 ~ 350010 Target04 (Int)

Input Register (3X)

Address Range Content

350203 ~ 350400 OCR01 ~ 99 (Int)

350401 ~ 350600 MODBUSINT00 ~ 99

350601 ~ 350800
MODBUSUINT00 ~ 99 

(Uint32)
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Holding Register (4X)

Address Range Content

40001 ~ 40051 MODBUSHSTR00

40052 ~ 40102 MODBUSHSTR01

40103 ~ 40153 MODBUSHSTR02

40154 ~ 40204 MODBUSHSTR03

40205 ~ 40255 MODBUSHSTR04

• Address Mapping – Holding Register (String) : MODBUSHSTR

Store Modbus custom output. The data type is ASCII. Its length is 51 words.

Holding Register (4X)

Address Range Content

40001 ~ 410200 MODBUSHSTR00 ~ 199
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Holding Register (4X)

Address Range Content

410201 ~ 410202 MODBUSHINT00

410203 ~ 410204 MODBUSHINT01

410205 ~ 410206 MODBUSHINT02

410207 ~ 410208 MODBUSHINT03

410209 ~ 410210 MODBUSHINT04

• Address Mapping – Holding Register (Int) : MODBUSHINT, MODBUSHUINT

Store Modbus custom output. The data type is Int32 and Uint32. Its length is 2 words.

Holding Register (4X)

Address Range Content

410201 ~ 411200 MODBUSHINT00 ~ 499

411201 ~ 412200 MODBUSHUINT00 ~ 499



000
001
002
003

Build Project – Protocols

• Address Mapping – Coil Status : System Control

Control VIC7000. Play project can be used even there is no admin logging in. The index of 

control files is followed the order listed in the Load Control File window of Control page

Coil Status (0X)

Address Content

00001
Play project.

1 = Play      0 = Stop

00002
Play control.

1 = Play      0 = Stop

00101 ~ 00300
Play control file with index 000 ~ 199.

1 = Play      0 = Stop
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• Link Config

1. Enter Link page : In administrator page

2. Choose Modbus

3. Enter Port : 502 (default)

4. Click Add

Remove Link

1

2

3

4
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• Link Testing : Use Modscan

1. Connect Settings : Connection → Connect

2. Choose Remote TCP/IP Server

3. Enter IP Address and Service Port

4. Click OK

1

2

3

4
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• Link Testing

5. Check got data : The data type of string is ASCII, and the data type of numeric data is 

Int32.
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REST(Representation State Transfer) is a software architectural style, which is used to 

facilitate the transfer of information between different software/programs on the network.

REST allows users to send URLs to access and manipulate network resources. It is commonly 

used in the IT industry. Most of REST API returning resources is XML or JSON. 

VIC7000 returning data is JSON.
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• Get Data

1. Call API : Open browser → Enter IP/restful in URL field

2. Check returning data

1

2
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• Get Data

3. Call Separately : Enter IP/restful/ocr/index in URL field, and returning data will be single 

data type. Target, target_color, target_pattern, color, pattern, calc can be called by this 

way.
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• Control VIC : Use Postman

1. Execute Postman           2.    Add new Request : Click New → Select Request

2

2
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• Control VIC : Use Postman

3. Enter Request name  

4. Choose used Collection : If there is no Collection, select + Create Collection 5.   Save

3

4

5
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• Control VIC : Use Postman

6. Choose PUT

7. Enter URL : IP/restful/put

6

6

7
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• Control VIC : Use Postman

8. Headers : Content-Type : application/x-www-form-urlencoded

8
8
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• Control VIC : Use Postman

9. Body : x-www-form-urlencoded

9
9
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• Control VIC : Use Postman

9. Body : Even play project can be used only when there is no admin logging in.

Play Project Play Control
Play Control File 

with index i

username
admin

or

user

admin

or

user

admin

or

user

password
123456

(default)

123456

(default)

123456

(default)

channel_type play play_control play_control_file

value 1 = Play    0 = Stop 1 = Play    0 = Stop 1 = Play    0 = Stop

index_value － － 0 ~ 199
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• Control VIC : Use Postman

9. Body : Sample : Play Project 10.    Send

10

9
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• Control VIC : Use Postman

11. Check Response

11

login_success
Whether logging in is successful.

1 = Successful   0 = Failed

rsp_status
Whether the command is executed 

successfully. 

1 = Successful   0 = Failed
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SQL, Structure Query Language, is used to manage database system. 

The scope of SQL includes data query, data manipulation, data definition, and data access control.

Query

SELECT “column”

FROM “table”

WHERE “condition”

GROUP BY “condition”

ORDER BY “[ASC, DESC]”

LIMIT “limitation”
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MySQL is an open-source relational database management system. Because of its high 

efficacy, low cost, and high reliability, MySQL has become a popular open-source database. 

VIC7000 utilizes MySQL to store data. Users can use another computer to connect to the 

database within VIC7000. 
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The database name within VIC7000 is named “vic”. There is a default account, username and 

password are vic_7000. This account can be used with VIC7000 computer.

If users want to get data remotely, they must add a new account with account root and its 

default password is 123456 (user can change it).

set password for ‘root’@’localhost’ = password(‘root’);
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After add a new user with account root, next step is to give this new user the authority to use “vic”

database. Then this new account can access in “vic” database to query or get data.

CREATE USER ‘test_user’@’%’ IDENTIFIED BY ‘test_user’;

GRANT ALL PRIVILEGES ON vic.* TO  ‘test_user’@’%’ ;
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• Link Testing : MySQL Workbench
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• Link Testing : MySQL Workbench

1. Connection Settings : Database → Connect to Database… → Hostname : IP → 

Username : test_user
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• Link Testing : MySQL Workbench

3. Enter password and click OK

4. Check database “vic” 
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• Link Testing : MySQL Workbench

6. Enter and execute commands : Create a new SQL tab for executing queries → Enter SQL 

command (This sample counting data in “vic”) → Form Editor
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• Control : Record the action of mouse and keyboard

1. Entry to Control Page : It must be used along with capture card input. When it’s recording, 

the capture card should get data continuously.
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• Control

• Controller Settings

Current File Path

Load : Load control file

Loop : Whether to play control 

file cyclically

Auto Run : Whether to play 

control file while project is playing

Auto Run Delay (ms)

Record/Stop Shortcut Key

Enable Scheduler

Scheduler Setting
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• Control

• Video Parameter

Adjust Image Size : Modifying the width and 

quality of the image and using grayscale to 

improve smoothness while recording control 

files

Adjusting video width

Adjusting video Quality

Grayscale

Video Signal
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• Control

2. Record Action : Click Record (press Record Shortcut Key) → The action of mouse and 

keyboard will be recorded → Click Stop (press Stop Shortcut Key)
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• Control

2. Record Action : Enter Name of control file → Click OK

The control file will be loaded automatically. Click Start to simulate playing the control file.
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• Control

• Scheduler Settings : Click Scheduler and Control Scheduler window will show up → 

Click Add
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• Control

• Scheduler Settings – interval : How often the 

control file should be played

Control File

Schedule method : Choose interval

Minute

Hour

Day

Clicking OK to finish
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• Control

• Scheduler Settings – At an exact time : Play control 

file once at a specific time 

Control File

Schedule Method : At an exact time

Minute

Hour

Day

Day of Week

* : Represent each time point in the field

Ex : If settings are minute-*, Hour-12, Day-25, Day of 

Week-*, then this control file will be repeated every 

minute at twelve o’clock on 25th every month.

If there is a set Day and Day of Week, 

the control file will be played only when 

two conditions are matched. 

Ex : if Day is set to 5, Day of Week is set 

to 1, then the control file will be played 

on 5th and Monday every month.

Clicking OK after setting up



Build Project – Control

• Serial Port Control

Set the serial port in System Settings. The status of serial port is based on connection of 

supplied COM cable, and it is displayed on the toolbar in the upper-right corner.   

If it is connected, project and control playing will be played, otherwise it will be paused.
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• Script : Entry to Script page
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• Script

• Use Parameter : Right-click on the target field
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• Script

• Use Parameter : Select a Targets button in the right-hand side field
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• Script Operator Num & Num Num & String String & String

Addition (+) +
convert number to string, 

then string add ups
+

Subtraction (-) - No action No action

Multiplication (*) * No action No action

Division (/) / No action No action

Less than (<)

Comparison

convert character to ASCII 

code, then compare it in 

order

convert character to ASCII 

code, then compare it in 

order

Equal (==)

Greater than (>)

Less than 

or Equal (<=)

Greater than 

or Equal (>=)

Not equal (!=)
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• Script

• Functions : Click Functions button

SEND.EMAIL : Send email automatically, see Advanced

SEND.LINE : Send LINE notify automatically, see Advanced

SEND.WECHAT : Send WeChat message automatically, see 

Advanced

SEND.WECHAT_P : Send WeChat message automatically, see 

Advanced

LOG : Record message in Log

PAGE_NO : A variable, the used page index currently

RESULT : Current recognition, 0 = Pass, 1 = NG, 2 = No Matching

CURRENT_TIME : A variable, current time to execute script
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• Script

• Functions : Click Functions button

PLAY.CONTROL_FILE : Play specific control file

PLAY.CONTROL_FILE_IQ : Play specific control file with input and 

queue property, see Advanced

PLAY.PROJECT : Play/Stop project

PLAY.CONTROL : Play/Stop control

WRITE.DATABASE : Whether recognition data is written into 

database

CHECK.COLOR : Check whether a color is twinkling

IF-ELSE : Conditional

ELSE IF : Conditional
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• Script

• LOG : Record message in Log

1. type : The color of the message recorded in Log, 0 : black, 1 : red, 2 : blue

2. message : The message that is needed to be recorded (string)

3. sec : Restrict execution again in a period of time (s)
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• Script

• PLAY.CONTROL_FILE : Play specific control file

1. control_file_name : Name of the control file that is about to play. 

The file can be picked from control file list

2. sec : Restrict execution again in a period of time (s)

Control file list

*While the current control file is being played, another control file is played, 

the current file will be stopped and the next file will start immediately.
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• Script

• PLAY.PROJECT : Play/Stop project

1. status : It could only be set to 0, means that it will only stop project
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• Script

• PLAY.CONTROL : Play/Stop control

1. status : Set the status of control

0 = Stop current all current controls

1 = Play the control file set in Control page
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• Script

• WRITE.DATABASE : Whether recognition data is written into database

1. status : Set the status of writing data into database

0 = Disable writing data into database

1 = Enable writing data into database
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• Script

• CHECK.COLOR : Detect whether a COLOR is twinkling

1. page_color : The color needed to be detected

2. calc : Store detection results

3. sec : detection time interval (int)

Detect COLOR01 on PAGE01 that is 

twinkling in 10 seconds, and the result 

will be stored in CALC00.
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• Script

• Apply : After edition is finished, click Apply(ctrl + s) and the script will take effect.
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• Script

• Sample : Use Script to determine the CALC value. If the recognition result on PAGE01 is 

greater than 0, set CALC as 1, otherwise set CALC as 0.



Build Project – Script

• Script

• Simulate : Enter Monitor page → Click Snap → Check Script execution result

CALC00 CALC01

CALC02 CALC03

CALC04 CALC05

CALC06 CALC07

CALC08 CALC09

CALC10 CALC11



Advanced

• SMTP

• Get Authority : If using Gmail, user needs to get access authority of email. First, enter 

Google account page



Advanced

• SMTP

• Get Authority : Enter safety page → Find Low security application access → Click Turn 

on access



Advanced

• SMTP

• Get Authority : Allow low security applications



Advanced

• SMTP

• Get Authority : If using Yahoo mail, user needs to get access authority of email. Enter 

account page for Yahoo homepage.



Advanced

• SMTP

• Get Authority : Enter Security page → Find Allow the use of applications with less 

secure login methods → Click to Allow access 



Advanced

• SMTP : Send Email Automatically

1. Link Settings : Enter Link page → Communication Mode : SMTP → Enter Server Address, 

Port, User Name, Password, Email → Click Add



Advanced

• SMTP : Send Email Automatically

1. Link Settings : Confirm SMTP link which has been added. Or remove it.



Advanced

• SMTP : Send Email Automatically

2. Edit Script : Enter Script page → Choose SEND.EMAIL in Functions field



Advanced

• SMTP : Send Email Automatically

2. Edit Script : Six parameters

1. id : Used SMTP link (string)

2. to : Recipient (string)

3. subject : mail subject (string)

4. body : mail body (string)

5. send image : Whether to transfer image when execute 

this command (1 : transfer, 0 : not transfer)

6. sec : Restrict execution again in a period of time (s)

1



Advanced

• SMTP : Send Email Automatically

2. Edit Script : Edition is finished → Click Apply (ctrl +s)



Advanced

• SMTP : Send Email Automatically

3. Simulate : Enter Monitor page → Click Snap → Check whether there is a mail



Advanced

• Line Notify

1. Get token : Go to the website of Line Notify (https://notify-bot.line.me/zh_TW/) → Click Sign In

→ Enter email account name and password

https://notify-bot.line.me/zh_TW/


Advanced

• Line Notify

1. Get token : Click account name → Click Personal page



Advanced

• Line Notify

1. Get token : Click Issuing token → Enter Name of token → Choose the chatroom which will 

receive message → Click Issued



Advanced

• Line Notify

1. Get token : Please copy the issued token



Advanced

• Line Notify

2. Link Settings : Enter Link page → Communication Mode : LINE Notify → Enter Token and 

custom GroupName → Click Add



Advanced

• Line Notify

2. Link Settings : Confirm the LINE Notify link which has been added. Or remove it.



Advanced

• Line Notify

3. Edit Script : Enter Script page → Choose SEND.LINE in Functions field



Advanced

• Line Notify

3. Edit Script : Four parameters

1. id : LINE Notify link (string)

2. message : The message that is needed to be sent (string)

3. send image : Whether to transfer image when execute 

this command (1 : transfer, 0 : not transfer)

4. sec : Restrict execution again in a period of time (s)

1



Advanced

• Line Notify

3. Edit Script : Edition is finished → Click Apply (ctrl +s)



Advanced

• Line Notify

4. Simulate : Enter Monitor page → Click Snap → Check if 

there is a message in LINE



Advanced

• WeChat

1. Get Information : Go to WeChat public platform website(https://mp.weixin.qq.com/debug/cgi-

bin/sandbox?t=sandbox/login) → Click log in → Use cell phone to scan QR code and login

https://mp.weixin.qq.com/debug/cgi-bin/sandbox?t=sandbox/login


Advanced

• WeChat

1. Get Information : After logging in, user needs to copy appID and appsecret



Advanced

• WeChat

2. Set templateID : Click New test patterns → Enter Template title and Template content



Advanced

• WeChat

2. templateID : Edition is finished, click submit.

Script Parameters Template corresponding content

keyword1 {{keyword1.DATA}}

keyword2 {{keyword2.DATA}}

keyword3 {{keyword3.DATA}}

Not Script 

Parameter
Template corresponding content

Current Time {{currentTime.DATA}}



Advanced

• WeChat

2. Set templateID : Generated templateID will be used in SEND.WECHAT and 

SEND.WECHAT_P



Advanced

• WeChat

3. Set openID : Use WeChat APP to scan the Test number QR code and follow the test 

public account. To receive message, user must follow the test public account.



Advanced

• WeChat

3. Set openID : After an account followed, the WeChat ID of this account, is called openID,  will 

show up and will be used in SEND.WECHAT_P



Advanced

• WeChat

4. Link Settings : Enter Link page → Communication Mode : WeChat → Enter appID and 

appsecret → Click Add



Advanced

• WeChat

4. Link Settings : Confirm the WeChat link which has been added. Or remove it.

To check if there is a new account following the test public account, click Update Group to 

refresh Number of groups.



Advanced

• WeChat

5. Edit Script : Enter Script page → Choose SEND.WECHAT and SEND.WECHAT_P in 

Functions field



Advanced

1

• WeChat

5. Edit Script : Six parameters. Send message to each user 

following the test public account.

1. id : WeChat link (string)

2. templateID : templateID (string)

3. keyword1 : The message will be sent as keyword1, which 

is same as {{keyword1.DATA}} in template (string)

4. keyword2 : The message will be sent as keyword2, which 

is same as {{keyword2.DATA}} in template (string)

5. keyword3 : The message will be sent as keyword3, which 

is same as {{keyword3.DATA}} in template (string)

6. sec : Restrict execution again in a period (s)



Advanced

• WeChat

5. Edit Script : Seven parameters. Send message to one user 

following the test public account.

1. id : WeChat link (string)

2. templateID : templateID (string)

3. openID : OpenID of recipent account (string)

4. keyword1 : The message will be sent as keyword1, which 

is same as {{keyword1.DATA}} in template (string)

5. keyword2 : The message will be sent as keyword2, which 

is same as {{keyword2.DATA}} in template (string)

6. keyword3 : The message will be sent as keyword3, which 

is same as {{keyword3.DATA}} in template (string)

7. sec : Restrict execution again in a period (s)

1



Advanced

• WeChat

5. Edit Script : Edition is finished → Click Apply (ctrl +s)



Advanced

• WeChat

6. Simulate : Entry to Monitor page → Click Snap → Check if there is a message in WeChat



Advanced

• Event Trigger

1. Link Settings – email : Enter Link page → Communication Mode : SMTP → Enter Server 

Address, Port, User Name, Password, Email → Click Add



Advanced

• Event Trigger

1. Link Settings – email : Confirm SMTP link which has been added. Or remove it.



Advanced

• Event Trigger

1. Link Settings – LINE Notify : Enter Link page → Communication Mode : LINE Notify → 

Enter Token, GroupName → Click Add



Advanced

• Event Trigger

1. Link Settings – LINE Notify : Confirm the LINE Notify link which has been added. 

Or remove it.



Advanced

• Event Trigger

1. Link Settings – WeChat : Enter Link page → Communication Mode : WeChat → Enter appID, 

appsecret → Click Add



Advanced

• Event Trigger

1. Link Settings – WeChat : Confirm the WeChat link which has been added. Or remove it.

To check if there is a new account following the test public account, click Update Group to 

refresh Number of groups.



Advanced

• Event Trigger

2. Set Event Condition – OCR : Click Event Condition → The window of Event Condition will 

show up



Advanced

• Event Trigger

2. Set Event Condition – OCR : Click Add → Set Comparison → Set Condition → Click OK

- ：Non compare

> ：Greater than

= ：Equal

< ：Less than

!= ：Not equal

=~ ：Including (for String only)



Advanced

• Event Trigger

2. Set Event Condition – COLOR, PATTERN : Click Event Condition → The window of Event 

Condition will show up



Advanced

• Event Trigger

2. Set Event Condition – COLOR, PATTERN : Click Add → Set Comparison → 

Set Condition → Click OK

- ：Non compare

= ：Equal

!= ：Not equal

=~ ：Including (for String only)



Advanced

• Event Trigger

Example – Set Event Condition – OCR : Set the condition of OCR01 greater than 200



Advanced

• Event Trigger

3. Set Event Trigger : Click Event Trigger → The window of Event Trigger will show up



Advanced

• Event Trigger

3. Set Event Trigger – email : Click Add → Event Trigger : Send Email, Set Interval Time, Link 

ID : SMTP link, whether to Send Image, Enter Recipient Address → Click OK



Advanced

• Event Trigger

3. Set Event Trigger – LINE Notify : Click Add → Event Trigger : Send Line, Set Interval Time, 

Link ID : LINE Notify link, whether to Send Image → Click OK



Advanced

• Event Trigger

3. Set Event Trigger – WeChat : Click Add → Event Trigger : Send WeChat, Set Interval Time, 

Link ID : WeChat link, Enter templateID → Click OK



Advanced

• Event Trigger

3. Set Event Trigger – WeChat_P : Click Add → Event Trigger : Send WeChat P, Set Interval 

Time, Link ID : WeChat link, Enter templateID, Enter openID → Click OK



Advanced

• Event Trigger

4. Simulation : Entry to Monitor page → Click Snap → Check if there is a new message

When the condition is met, the item will be

displayed in red text



Advanced

• Control – Input

1. Record Control File : Entry to Control page → Click Record (press Record Shortcut Key)

→ The action of mouse and keyboard will be recorded → Click Stop (press Stop Shortcut 

Key) → Enter Name of control file → Click OK

When control play completed, the input data field 

should be enterable 



Advanced

• Control – Input

1. Record Control File : Entry the window of Load Control File

The index of control files is followed the order listed in the Load Control File window of 

Control page. Another way is to put cursor on a file name, the index of the control file will show up. 

00
01
02
03



Advanced

• Control – Input

2. Control File Setting – Input : Entry to the window of Load Control File → Check Input

If Input is checked, VIC7000 will enter the characters stored in corresponding field after the 

control file playing is finished.



Advanced

• Control – Input
2. Control File Setting – Queue : Entry to the window of Load Control File → Check Queue

In normal, while the current control file is being played, another control file is start to play, 

the current file will be stopped and the new ones will start immediately.

If Queue is check, the control file will be played after the current file completely played. 



Advanced

• Control – Input
3. Set Input Content – Script : Entry to the Script page→ Set value of MODBUSHSTRn

n is the index of MODBUSHSTR, and MODBUSHSTRn is the content that will be entered 

after the control file with same index playing completely played. For example, MODBUSHSTR00 is 

the content that will be entered after the control file with index 00 playing is finished.



Advanced

• Control – Input

Example – Set Input Content – Script : Use Script set the value of MODBUSHSTR00 to -12. 

Then clicking Snap in Monitor Mode, which execute Script.



Advanced

• Control – Input
3. Set Input Content – Modbus TCP : VIC7000 is little-endian system. Data should be read 

from lower bits. Data should also be written from lower bits.

A B C \0

42 41 0 43

4x0001 4x0002

MODBUSHSTR00

Modbus Holding Register



Advanced

• Control – Input
3. Set Input Content – Modbus TCP : Set the value of MODBUSHSTRn, and the data type is

ASCII code (8bits). A register (16bits) can store 2 ASCII code, and the ASCII code will be 

transfered to character. n is the index of MODBUSHSTR, and MODBUSHSTRn is the content 

that will be entered after the control file with same index playing is completed. For example, 

MODBUSHSTR00 is the content that will be entered after the control file with index 00 is 

finished playing.

Holding Register (4X)

Address Range Content

40001 ~ 410200 MODBUSHSTR00 ~ 199

A MODBUSHSTR can store 101 ASCII code. 

Another word, it can store 101 characters. 

Holding Register (4X)

Address Range Content

40001 ~ 40051 MODBUSHSTR00

40052 ~ 40102 MODBUSHSTR01

40103 ~ 40153 MODBUSHSTR02

40154 ~ 40204 MODBUSHSTR03

40205 ~ 40255 MODBUSHSTR04



Advanced

• Control – Input

Example – Set Input Content – Modbus TCP : Use Modscan(Hex mode) to set the value of 

MODBUSHSTR00 to -12

- 1 2 \0

31 2D 0 32

4x0001 4x0002

MODBUSHSTR00

Modbus Holding Register



Advanced

• Control – Input
3. Set Input Content – RESTful API : Use PUT to set the content that will be entered. 

index_value is corresponding to the index of control file, and the set content will be entered 

after the corresponding control file completely played. For example, MODBUSHSTR00 is 

the content that will be entered after the control file with index 00 playing is finished. 

Here use Postman for testing

Headers：Content-Type: application/x-www-form-urlencoded

Body：x-www-form-urlencoded

Set the content that 

will be entered

username
admin

or

user

password
123456

(default)

channel_type write_modbush_string

index_value 0 ~ 199

content
The content that will be 

entered



Advanced

• Control – Input

Example – Set Input Content – RESTful API : Use Postman to set the content of index_value

00 to -12. Check response after sending request

login_success
Whether logging in is successful.

1 = Successful   0 = Failed

rsp_status
Whether the command is executed 

1 = Successful   0 = Failed



Advanced

• Control – Input
3. Set Input Content – SQL : Use controller_table in database “vic” to set the content that will

be entered. id is corresponding to the index of control file, and value in same row will be 

entered after the corresponding control file completely played.  When VIC7000 entering data, 

the content set by Script, Modbus TCP, RESTful API is prior to be used. For example, the value 

in same row id 0 is the content that will be entered after the control file with index 00 is finished 

playing. 



Advanced

• Control – Input

3. Set Input Content – SQL : Use UPDATE to set the content that will be entered. index is the 

index of control file, and val is the content.

Add a SQL file → edit the command → Click Execute

UPDATE vic.controller_input SET value=‘val’ WHERE id=‘index’;

1

3

2



Advanced

• Control – Input

Example – Set Input Content – SQL : Use Postman to set the value of index_value 0 to -1 User 

can use SELECT to check whether the set value is correct after executing the command

SELECT * FROM vic.controller_table;

UPDATE vic.controller_table SET value=‘-12’ WHERE id=‘0’;



Advanced

• Control – Input

4. Trigger Control File – Script : Enter Script page → Choose PLAY.CONTROL_FILE_IQ in 

Functions field



Advanced

• Control – Input

• PLAY.CONTROL_FILE_IQ : Play specific control file with input and 

queue property

1. control_file_name : Name of the control file that is about to play. 

The file can be picked from control file list

2. sec : Restrict execution again in a period of time (s)

Control file list

*If it needs to use input or queue property, user must check them in Load 

Control File window



Advanced

• Control – Input

Example – Trigger Control File – Script : Use PLAY.CONTROL_FILE_IQ to trigger the control 

file named 00. After edition is finished, click Apply(ctrl + s) and the script will take effect.



Advanced

• Control – Input

4. Trigger Control File – Modbus TCP : Set the value of specific Modbus address, and it can 

trigger the corresponding control file

Coil Status (0X)

Address Content

00101 ~ 00300
Play control file with index 00~199

1 = Play 0 = Stop



Advanced

• Control – Input

Example – Trigger Control File – Modbus TCP : Double click on the value field of address 

00101 and update the value to 1(On), then it will trigger the control file with index 00



Advanced

• Control – Input

4. Trigger Control File – RESTful API : Use PUT to trigger the control file

Play control file with 

index i

username
admin

or

user

password
123456

(default)

channel_type play_control_file

value
1 = Play

0 = Stop

index_value 0 ~ 199



Advanced

• Control – Input

4. Trigger Control File – RESTful API : Check response

login_success
Whether logging in is 

successful.

1 = Successful   0 = Failed

rsp_status
Whether the command is 

executed successfully. 

1 = Successful   0 = Failed



Advanced

• Control – Input

Example – Trigger Control File – RESTful API : Trigger the control file with index 00. Send the 

request after setting up the parameters



Advanced

• Control – Input

Example – Trigger Control File – RESTful API : Check response after sending the request

login_success
Whether logging in is 

successful.

1 = Successful   0 = Failed

rsp_status
Whether the command is 

executed successfully. 

1 = Successful   0 = Failed



Advanced

• Control – Input

4. Trigger Control File – SQL : Use key_table in database “vic” to trigger control file. Use 

UPDATE to trigger the specific control file. index is the index of control file.

User can use SELECT to get the status of Control, 0 = Stop, 1 = Playing

UPDATE vic.key_table SET value=‘index’ WHERE id=‘1’; SELECT value FROM vic.key_table WHERE id=‘2’;



Advanced

• Control – Input

Example – Trigger Control File – SQL : Use UPDATE to trigger the control file with index 00, 

use SELECT to get the status of Control

UPDATE vic.key_table SET value=‘0’ WHERE id=‘1’;

SELECT value FROM vic.key_table WHERE id=‘2’;



Advanced

• Control – Input

5. Simulate : This example illustrates how to use control file to make the notepad enterable and 

enter -12 after the control file playing is finished playing. When simulating, user can check :

✓ Whether playing control file is correct

✓ Whether entered content is correct



Appendix

• Rename

1. Rename : Enter Recognition Config Page → Right-click TARGET、TARGET_COLOR、

TARGET_PATTERN、OCR、COLOR、PATTERN → Choose Rename

Here use TARGET and OCR to demonstrate this function



Appendix

• Rename

1. Rename : Enter the new Name (not repeated) → Click OK, then TARGET and OCR will 

be renamed.



Appendix

• Rename

• Check Rename : Rename content will be denoted beside the TARGET and OCR



Appendix

• Rename

• Check Rename : Click the renamed TARGET and OCR, and the original name will show up



Appendix

• Rename

• Check Rename : In Database page, select renamed TARGET & OCR, and the new name will 

show up



Appendix

• Rename

• Check Rename : In System Settings, Click OCR Name Conversion Table, and the table 

listing renamed content will show up, the JSON file and can be export to .txt



Appendix

• Rename

• Check Rename : Use with RESTful API, and Enter IP/restful/ocr_map in URL field. 

The OCR Name Conversion Table will show as below.



Appendix

• Rename

• Recover : Enter Recognition Config Page → Right-click renamed TARGET and OCR →

Choose Rename



Appendix

• Rename

• Recover : Empty new Name → Click OK, and TARGET & OCR will be recovered to default 

name.
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